The Apache mod_csr module for httpd

Build: #87 was successful

Job: Build Job - CentOS8 (Interop) was successful

Stages & jobs

  1. Default Stage

  2. Release Stage

    Requires a user to start manually

Job result summary

Completed
Duration
49 seconds
Agent
coconut.redwax.eu
Revisions
mod_ca - master
ffce887704991060645e8233f26927e0a998bbd4 ffce887704991060645e8233f26927e0a998bbd4
mod_csr - master
43b74e92528798ff89c7e293d9173970e3c7711b 43b74e92528798ff89c7e293d9173970e3c7711b
Successful since
#69 ()

Error summary

The build generated some errors. See the full build log for more details.

                 from /usr/include/apr-1/apr_strings.h:48,
                 from ./mod_ca_crl.c:23:
/usr/include/features.h:381:4: warning: #warning _FORTIFY_SOURCE requires compiling with optimization (-O) [-Wcpp]
#  warning _FORTIFY_SOURCE requires compiling with optimization (-O)
    ^~~~~~~
/usr/lib64/apr-1/build/libtool --silent --mode=link gcc -Wl,-z,relro,-z,now   -o ./mod_ca_crl.la  -lssl -lcrypto -rpath /usr/lib64/httpd/modules -module -avoid-version    ./mod_ca_crl.lo
/usr/lib64/apr-1/build/libtool --silent --mode=compile gcc -prefer-pic -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -Wp,-D_GLIBCXX_ASSERTIONS -fexceptions -fstack-protector-strong -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1 -m64 -mtune=generic -fasynchronous-unwind-tables -fstack-clash-protection -fcf-protection  -DLINUX -D_REENTRANT -D_GNU_SOURCE -pthread -I/usr/include/httpd  -I/usr/include/apr-1   -I/usr/include/apr-1  -O0 -g -Wall  -c -o ./mod_ca_disk.lo ./mod_ca_disk.c && touch ./mod_ca_disk.slo
In file included from /usr/include/sys/types.h:25,
                 from /usr/include/apr-1/apr-x86_64.h:164,
                 from /usr/include/apr-1/apr.h:19,
                 from /usr/include/apr-1/apr_strings.h:48,
                 from ./mod_ca_disk.c:23:
/usr/include/features.h:381:4: warning: #warning _FORTIFY_SOURCE requires compiling with optimization (-O) [-Wcpp]
#  warning _FORTIFY_SOURCE requires compiling with optimization (-O)
    ^~~~~~~
/usr/lib64/apr-1/build/libtool --silent --mode=link gcc -Wl,-z,relro,-z,now   -o ./mod_ca_disk.la  -lssl -lcrypto -rpath /usr/lib64/httpd/modules -module -avoid-version    ./mod_ca_disk.lo
/usr/lib64/apr-1/build/libtool --silent --mode=compile gcc -prefer-pic -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -Wp,-D_GLIBCXX_ASSERTIONS -fexceptions -fstack-protector-strong -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1 -m64 -mtune=generic -fasynchronous-unwind-tables -fstack-clash-protection -fcf-protection  -DLINUX -D_REENTRANT -D_GNU_SOURCE -pthread -I/usr/include/httpd  -I/usr/include/apr-1   -I/usr/include/apr-1  -O0 -g -Wall  -c -o ./mod_ca_engine.lo ./mod_ca_engine.c && touch ./mod_ca_engine.slo
In file included from /usr/include/sys/types.h:25,
                 from /usr/include/apr-1/apr-x86_64.h:164,
                 from /usr/include/apr-1/apr.h:19,
                 from /usr/include/apr-1/apr_strings.h:48,
                 from ./mod_ca_engine.c:24:
/usr/include/features.h:381:4: warning: #warning _FORTIFY_SOURCE requires compiling with optimization (-O) [-Wcpp]
#  warning _FORTIFY_SOURCE requires compiling with optimization (-O)
    ^~~~~~~
/usr/lib64/apr-1/build/libtool --silent --mode=link gcc -Wl,-z,relro,-z,now   -o ./mod_ca_engine.la  -lssl -lcrypto -rpath /usr/lib64/httpd/modules -module -avoid-version    ./mod_ca_engine.lo
/usr/lib64/apr-1/build/libtool --silent --mode=compile gcc -prefer-pic -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -Wp,-D_GLIBCXX_ASSERTIONS -fexceptions -fstack-protector-strong -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1 -m64 -mtune=generic -fasynchronous-unwind-tables -fstack-clash-protection -fcf-protection  -DLINUX -D_REENTRANT -D_GNU_SOURCE -pthread -I/usr/include/httpd  -I/usr/include/apr-1   -I/usr/include/apr-1  -O0 -g -Wall  -c -o ./mod_ca.lo ./mod_ca.c && touch ./mod_ca.slo
In file included from /usr/include/sys/types.h:25,
                 from /usr/include/apr-1/apr-x86_64.h:164,
                 from /usr/include/apr-1/apr.h:19,
                 from /usr/include/httpd/ap_hooks.h:39,
                 from /usr/include/httpd/ap_config.h:25,
                 from /usr/include/httpd/httpd.h:44,
                 from ./mod_ca.c:22:
/usr/include/features.h:381:4: warning: #warning _FORTIFY_SOURCE requires compiling with optimization (-O) [-Wcpp]
#  warning _FORTIFY_SOURCE requires compiling with optimization (-O)
    ^~~~~~~
/usr/lib64/apr-1/build/libtool --silent --mode=link gcc -Wl,-z,relro,-z,now   -o ./mod_ca.la  -lssl -lcrypto -rpath /var/lib/atlassian-bamboo-agent/home/temp/httpd-interop/usr/lib64/httpd/modules -module -avoid-version    ./mod_ca.lo
/usr/lib64/httpd/build/instdso.sh SH_LIBTOOL='/usr/lib64/apr-1/build/libtool' ./mod_ca.la /var/lib/atlassian-bamboo-agent/home/temp/httpd-interop/usr/lib64/httpd/modules
chmod 755 /var/lib/atlassian-bamboo-agent/home/temp/httpd-interop/usr/lib64/httpd/modules/mod_ca.so
/usr/lib64/apr-1/build/libtool --silent --mode=compile gcc -prefer-pic -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -Wp,-D_GLIBCXX_ASSERTIONS -fexceptions -fstack-protector-strong -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1 -m64 -mtune=generic -fasynchronous-unwind-tables -fstack-clash-protection -fcf-protection  -DLINUX -D_REENTRANT -D_GNU_SOURCE -pthread -I/usr/include/httpd  -I/usr/include/apr-1   -I/usr/include/apr-1  -O0 -g -Wall  -c -o ./mod_ca_simple.lo ./mod_ca_simple.c && touch ./mod_ca_simple.slo
In file included from /usr/include/sys/types.h:25,
                 from /usr/include/apr-1/apr-x86_64.h:164,
                 from /usr/include/apr-1/apr.h:19,
                 from /usr/include/apr-1/apr_strings.h:48,
                 from ./mod_ca_simple.c:23:
/usr/include/features.h:381:4: warning: #warning _FORTIFY_SOURCE requires compiling with optimization (-O) [-Wcpp]
#  warning _FORTIFY_SOURCE requires compiling with optimization (-O)
    ^~~~~~~
/usr/lib64/apr-1/build/libtool --silent --mode=link gcc -Wl,-z,relro,-z,now   -o ./mod_ca_simple.la  -lssl -lcrypto -rpath /var/lib/atlassian-bamboo-agent/home/temp/httpd-interop/usr/lib64/httpd/modules -module -avoid-version    ./mod_ca_simple.lo
/usr/lib64/httpd/build/instdso.sh SH_LIBTOOL='/usr/lib64/apr-1/build/libtool' ./mod_ca_simple.la /var/lib/atlassian-bamboo-agent/home/temp/httpd-interop/usr/lib64/httpd/modules
chmod 755 /var/lib/atlassian-bamboo-agent/home/temp/httpd-interop/usr/lib64/httpd/modules/mod_ca_simple.so
/usr/lib64/apr-1/build/libtool --silent --mode=compile gcc -prefer-pic -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -Wp,-D_GLIBCXX_ASSERTIONS -fexceptions -fstack-protector-strong -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1 -m64 -mtune=generic -fasynchronous-unwind-tables -fstack-clash-protection -fcf-protection  -DLINUX -D_REENTRANT -D_GNU_SOURCE -pthread -I/usr/include/httpd  -I/usr/include/apr-1   -I/usr/include/apr-1  -O0 -g -Wall  -c -o ./mod_ca_ldap.lo ./mod_ca_ldap.c && touch ./mod_ca_ldap.slo
In file included from /usr/include/sys/types.h:25,
                 from /usr/include/apr-1/apr-x86_64.h:164,
                 from /usr/include/apr-1/apr.h:19,
                 from /usr/include/apr-1/apr_strings.h:48,
                 from ./mod_ca_ldap.c:24:
/usr/include/features.h:381:4: warning: #warning _FORTIFY_SOURCE requires compiling with optimization (-O) [-Wcpp]
#  warning _FORTIFY_SOURCE requires compiling with optimization (-O)
    ^~~~~~~
/usr/lib64/apr-1/build/libtool --silent --mode=link gcc -Wl,-z,relro,-z,now   -o ./mod_ca_ldap.la  -lssl -lcrypto -rpath /var/lib/atlassian-bamboo-agent/home/temp/httpd-interop/usr/lib64/httpd/modules -module -avoid-version    ./mod_ca_ldap.lo
/usr/lib64/httpd/build/instdso.sh SH_LIBTOOL='/usr/lib64/apr-1/build/libtool' ./mod_ca_ldap.la /var/lib/atlassian-bamboo-agent/home/temp/httpd-interop/usr/lib64/httpd/modules
chmod 755 /var/lib/atlassian-bamboo-agent/home/temp/httpd-interop/usr/lib64/httpd/modules/mod_ca_ldap.so
/usr/lib64/apr-1/build/libtool --silent --mode=compile gcc -prefer-pic -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -Wp,-D_GLIBCXX_ASSERTIONS -fexceptions -fstack-protector-strong -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1 -m64 -mtune=generic -fasynchronous-unwind-tables -fstack-clash-protection -fcf-protection  -DLINUX -D_REENTRANT -D_GNU_SOURCE -pthread -I/usr/include/httpd  -I/usr/include/apr-1   -I/usr/include/apr-1  -O0 -g -Wall  -c -o ./mod_ca_crl.lo ./mod_ca_crl.c && touch ./mod_ca_crl.slo
In file included from /usr/include/sys/types.h:25,
                 from /usr/include/apr-1/apr-x86_64.h:164,
                 from /usr/include/apr-1/apr.h:19,
                 from /usr/include/apr-1/apr_strings.h:48,
                 from ./mod_ca_crl.c:23:
/usr/include/features.h:381:4: warning: #warning _FORTIFY_SOURCE requires compiling with optimization (-O) [-Wcpp]
#  warning _FORTIFY_SOURCE requires compiling with optimization (-O)
    ^~~~~~~
/usr/lib64/apr-1/build/libtool --silent --mode=link gcc -Wl,-z,relro,-z,now   -o ./mod_ca_crl.la  -lssl -lcrypto -rpath /var/lib/atlassian-bamboo-agent/home/temp/httpd-interop/usr/lib64/httpd/modules -module -avoid-version    ./mod_ca_crl.lo
/usr/lib64/httpd/build/instdso.sh SH_LIBTOOL='/usr/lib64/apr-1/build/libtool' ./mod_ca_crl.la /var/lib/atlassian-bamboo-agent/home/temp/httpd-interop/usr/lib64/httpd/modules
chmod 755 /var/lib/atlassian-bamboo-agent/home/temp/httpd-interop/usr/lib64/httpd/modules/mod_ca_crl.so
/usr/lib64/apr-1/build/libtool --silent --mode=compile gcc -prefer-pic -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -Wp,-D_GLIBCXX_ASSERTIONS -fexceptions -fstack-protector-strong -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1 -m64 -mtune=generic -fasynchronous-unwind-tables -fstack-clash-protection -fcf-protection  -DLINUX -D_REENTRANT -D_GNU_SOURCE -pthread -I/usr/include/httpd  -I/usr/include/apr-1   -I/usr/include/apr-1  -O0 -g -Wall  -c -o ./mod_ca_disk.lo ./mod_ca_disk.c && touch ./mod_ca_disk.slo
In file included from /usr/include/sys/types.h:25,
                 from /usr/include/apr-1/apr-x86_64.h:164,
                 from /usr/include/apr-1/apr.h:19,
                 from /usr/include/apr-1/apr_strings.h:48,
                 from ./mod_ca_disk.c:23:
/usr/include/features.h:381:4: warning: #warning _FORTIFY_SOURCE requires compiling with optimization (-O) [-Wcpp]
#  warning _FORTIFY_SOURCE requires compiling with optimization (-O)
    ^~~~~~~
/usr/lib64/apr-1/build/libtool --silent --mode=link gcc -Wl,-z,relro,-z,now   -o ./mod_ca_disk.la  -lssl -lcrypto -rpath /var/lib/atlassian-bamboo-agent/home/temp/httpd-interop/usr/lib64/httpd/modules -module -avoid-version    ./mod_ca_disk.lo
/usr/lib64/httpd/build/instdso.sh SH_LIBTOOL='/usr/lib64/apr-1/build/libtool' ./mod_ca_disk.la /var/lib/atlassian-bamboo-agent/home/temp/httpd-interop/usr/lib64/httpd/modules
chmod 755 /var/lib/atlassian-bamboo-agent/home/temp/httpd-interop/usr/lib64/httpd/modules/mod_ca_disk.so
/usr/lib64/apr-1/build/libtool --silent --mode=compile gcc -prefer-pic -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -Wp,-D_GLIBCXX_ASSERTIONS -fexceptions -fstack-protector-strong -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1 -m64 -mtune=generic -fasynchronous-unwind-tables -fstack-clash-protection -fcf-protection  -DLINUX -D_REENTRANT -D_GNU_SOURCE -pthread -I/usr/include/httpd  -I/usr/include/apr-1   -I/usr/include/apr-1  -O0 -g -Wall  -c -o ./mod_ca_engine.lo ./mod_ca_engine.c && touch ./mod_ca_engine.slo
In file included from /usr/include/sys/types.h:25,
                 from /usr/include/apr-1/apr-x86_64.h:164,
                 from /usr/include/apr-1/apr.h:19,
                 from /usr/include/apr-1/apr_strings.h:48,
                 from ./mod_ca_engine.c:24:
/usr/include/features.h:381:4: warning: #warning _FORTIFY_SOURCE requires compiling with optimization (-O) [-Wcpp]
#  warning _FORTIFY_SOURCE requires compiling with optimization (-O)
    ^~~~~~~
/usr/lib64/apr-1/build/libtool --silent --mode=link gcc -Wl,-z,relro,-z,now   -o ./mod_ca_engine.la  -lssl -lcrypto -rpath /var/lib/atlassian-bamboo-agent/home/temp/httpd-interop/usr/lib64/httpd/modules -module -avoid-version    ./mod_ca_engine.lo
/usr/lib64/httpd/build/instdso.sh SH_LIBTOOL='/usr/lib64/apr-1/build/libtool' ./mod_ca_engine.la /var/lib/atlassian-bamboo-agent/home/temp/httpd-interop/usr/lib64/httpd/modules
chmod 755 /var/lib/atlassian-bamboo-agent/home/temp/httpd-interop/usr/lib64/httpd/modules/mod_ca_engine.so
/usr/lib64/apr-1/build/libtool --silent --mode=compile gcc -prefer-pic -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -Wp,-D_GLIBCXX_ASSERTIONS -fexceptions -fstack-protector-strong -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1 -m64 -mtune=generic -fasynchronous-unwind-tables -fstack-clash-protection -fcf-protection  -DLINUX -D_REENTRANT -D_GNU_SOURCE -pthread -I/usr/include/httpd  -I/usr/include/apr-1   -I/usr/include/apr-1  -O0 -g -Wall -I/var/lib/atlassian-bamboo-agent/home/temp/httpd-interop/usr/include/httpd -I/usr/include/httpd  -c -o ./mod_csr.lo ./mod_csr.c && touch ./mod_csr.slo
In file included from /usr/include/sys/types.h:25,
                 from /usr/include/apr-1/apr-x86_64.h:164,
                 from /usr/include/apr-1/apr.h:19,
                 from /usr/include/apr-1/apr_strings.h:48,
                 from ./mod_csr.c:26:
/usr/include/features.h:381:4: warning: #warning _FORTIFY_SOURCE requires compiling with optimization (-O) [-Wcpp]
#  warning _FORTIFY_SOURCE requires compiling with optimization (-O)
    ^~~~~~~
/usr/lib64/apr-1/build/libtool --silent --mode=link gcc -Wl,-z,relro,-z,now   -o ./mod_csr.la  -lssl -lcrypto -rpath /usr/lib64/httpd/modules -module -avoid-version    ./mod_csr.lo
/usr/lib64/apr-1/build/libtool --silent --mode=compile gcc -prefer-pic -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -Wp,-D_GLIBCXX_ASSERTIONS -fexceptions -fstack-protector-strong -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1 -m64 -mtune=generic -fasynchronous-unwind-tables -fstack-clash-protection -fcf-protection  -DLINUX -D_REENTRANT -D_GNU_SOURCE -pthread -I/usr/include/httpd  -I/usr/include/apr-1   -I/usr/include/apr-1  -O0 -g -Wall -I/var/lib/atlassian-bamboo-agent/home/temp/httpd-interop/usr/include/httpd -I/usr/include/httpd  -c -o ./mod_csr.lo ./mod_csr.c && touch ./mod_csr.slo
In file included from /usr/include/sys/types.h:25,
                 from /usr/include/apr-1/apr-x86_64.h:164,
                 from /usr/include/apr-1/apr.h:19,
                 from /usr/include/apr-1/apr_strings.h:48,
                 from ./mod_csr.c:26:
/usr/include/features.h:381:4: warning: #warning _FORTIFY_SOURCE requires compiling with optimization (-O) [-Wcpp]
#  warning _FORTIFY_SOURCE requires compiling with optimization (-O)
    ^~~~~~~
/usr/lib64/apr-1/build/libtool --silent --mode=link gcc -Wl,-z,relro,-z,now   -o ./mod_csr.la  -lssl -lcrypto -rpath /var/lib/atlassian-bamboo-agent/home/temp/httpd-interop/usr/lib64/httpd/modules -module -avoid-version    ./mod_csr.lo
/usr/lib64/httpd/build/instdso.sh SH_LIBTOOL='/usr/lib64/apr-1/build/libtool' ./mod_csr.la /var/lib/atlassian-bamboo-agent/home/temp/httpd-interop/usr/lib64/httpd/modules
chmod 755 /var/lib/atlassian-bamboo-agent/home/temp/httpd-interop/usr/lib64/httpd/modules/mod_csr.so